$re = '/(?:ht|f)tps?:\/\/\w+\.\w{2}+[\/\w-.]+/i';
$str = 'http://matthiasweiss.at/asd/asd
ftp://hallo.welt
https://hallowelt.jpg
http://asdasd.aa/jojoji.jiji
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);