using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bv(\d+\.)+\d+\b";
string input = @"ABCDEF v3.4.2 GHI KLMN
ABCDEF v33.44.222 GHI KLMN
ABCDEF v3.4.2.1 GHI KLMN
DoNotv3.4.2CaptureThis
Do-v3.4.2-CaptureThis";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}