$re = '/\b\d\d:\d\d\b/';
$str = 'word word word (15:00 - - - 16:00 - - - 21:00)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);