# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\"Core #3 VID\",)\n \"SensorValue\": \"[0-9]+(\,[0-9]+)?"
test_str = ("[\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Virtual Memory Commited\",\n"
" \"SensorValue\": \"31385\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Virtual Memory Available\",\n"
" \"SensorValue\": \"5951\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Virtual Memory Load\",\n"
" \"SensorValue\": \"84\",\n"
" \"SensorUnit\": \"%\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Physical Memory Used\",\n"
" \"SensorValue\": \"30134\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Physical Memory Available\",\n"
" \"SensorValue\": \"2338\",\n"
" \"SensorUnit\": \"MB\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Physical Memory Load\",\n"
" \"SensorValue\": \"92,7\",\n"
" \"SensorUnit\": \"%\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"System\",\n"
" \"SensorName\": \"Page File Usage\",\n"
" \"SensorValue\": \"27,2209569027549\",\n"
" \"SensorUnit\": \"%\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #0 VID\",\n"
" \"SensorValue\": \"0,7376708984375\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #1 VID\",\n"
" \"SensorValue\": \"0,73828125\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #2 VID\",\n"
" \"SensorValue\": \"0,73828125\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #3 VID\",\n"
" \"SensorValue\": \"0,7449951171875\",\n"
" \"SensorUnit\": \"V\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #0 Clock\",\n"
" \"SensorValue\": \"983,934044334975\",\n"
" \"SensorUnit\": \"MHz\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #1 Clock\",\n"
" \"SensorValue\": \"983,934044334975\",\n"
" \"SensorUnit\": \"MHz\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },\n"
" {\n"
" \"SensorApp\": \"HWiNFO\",\n"
" \"SensorClass\": \"CPU [#0]: Intel Xeon E3-1225 v3\",\n"
" \"SensorName\": \"Core #2 Clock\",\n"
" \"SensorValue\": \"983,934044334975\",\n"
" \"SensorUnit\": \"MHz\",\n"
" \"SensorUpdateTime\": 1558534280\n"
" },")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.