$re = '/(?>\d+|[A-Z][a-z]*|[a-z]+)(?!$)/m';
$str = 'foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar';
$subst = "$0-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;