package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?<pre>T)?(?<mid>T[A-Z]))?(?<post>T)?$`)
var str = `TTT
TTU
TUT
TT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}