$re = '@<div class="yt">([\s\S]*?)</div>@m';
$str = '<div class="yt">
<iframe>....Video code....</iframe>
</div>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;