package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\{(.*?)\}`)
var str = `${FNAME} ${LNAME} ${123}`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}