using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(password|pwd|pass) *= *+((?="".*"")""[^&{][^\s]*""|(?='.*')'[^&{][^\s]*'|(?=[^""'{&].*)[^\s]*)$";
string input = @"password = ""test123ABc#&$""
pwd=test123ABc#&$
pwd = 'test123ABc#&$'
pass = 'test123456&'
password=&testpw
pwd = ""{test123@#""
password = ""&&test123""
pass={test123@";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}