$re = '~(?<=/)[^/_]+(?=_[^/]*$)~m';
$str = 'COUNTRY/CITY/street_number_floor_tel';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);