package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http:\/\/mywebsite\.com\/([a-zA-Z]+)$`)
var str = `http://mywebsite.com/1234
http://mywebsite.com/foo
http://mywebsite.com/bar
http://google.com
http://mywebsite.com/bar6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}