using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"R['’]?e['’]?n['’]?e['’]?e['’]?s";
string input = @"Basically I want to show Renee’s and Renee's in the paragraph displayed to the user and highlight the whole word even if the user searches for Renees.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}