#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[fF][eE]80:(?::[0-9a-fA-F]{1,4}){2,2}(?:%[0-9a-zA-Z]{1,})?"
Local $sString = "fe80::dead:beef%eth0" & @CRLF & _
"fe80::dead:beef:dead:beef%eth0" & @CRLF & _
"fe80:dead:beef:dead:beef:dead:beef:dead%eth0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")