$re = '/[fF][eE]80:(?::[0-9a-fA-F]{1,4}){2,2}(?:%[0-9a-zA-Z]{1,})?/m';
$str = 'fe80::dead:beef%eth0
fe80::dead:beef:dead:beef%eth0
fe80:dead:beef:dead:beef:dead:beef:dead%eth0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);