re = /[fF][eE]80:(?::[0-9a-fA-F]{1,4}){2,2}(?:%[0-9a-zA-Z]{1,})?/m
str = 'fe80::dead:beef%eth0
fe80::dead:beef:dead:beef%eth0
fe80:dead:beef:dead:beef:dead:beef:dead%eth0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end