const regex = /\W+([a-zA-Z])\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W+([a-zA-Z])\\b', 'gm')
const str = `Anti-Candida a ингибинов`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);