use strict;
my $str = 'Anti-Candida a ингибинов';
my $regex = qr/\W+([a-zA-Z])\b/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";