#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h*\([^)]*\b(?:picture|see|lorem)\b[^)]*\)"
Local $sString = "Hello world (see below)." & @CRLF & _
"Lorem ipsum(there is a picture here) world!" & @CRLF & _
"Attack on titan (is lorem) great but (should not be removed)." & @CRLF & _
"Hello world see below." & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)