using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*\([^)]*\b(?:picture|see|lorem)\b[^)]*\)";
string substitution = @"";
string input = @"Hello world (see below).
Lorem ipsum(there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Hello world see below.
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}