// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\h*\([^)]*\b(?:picture|see|lorem)\b[^)]*\)").unwrap();
let string = "Hello world (see below).
Lorem ipsum(there is a picture here) world!
Attack on titan (is lorem) great but (should not be removed).
Hello world see below.
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}