using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:###)?([^# \n]+))(?=$|(?:###[^# ]+)*[^\n]*?(http:\/\/[^\n]+))(?: http:\/\/[^\n]+)?";
string substitution = @"$1 $2\n";
string input = @"a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn http://www.zjmainstay.cn/my-regexp
a1@zjmainstay.cn###a2@zjmainstay.cn###a3@zjmainstay.cn###a4@zjmainstay.cn###a5@zjmainstay.cn http://www.zjmainstay.cn/deep-regexp";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}