#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)((?:(?:void|unsigned|signed|long|short|float|double|int|char|\*)(?:\s*))+)(\w+)\s*\("
Local $sString = "#include <stdio.h>" & @CRLF & _
"" & @CRLF & _
"unsigned int* fun1(void);" & @CRLF & _
"" & @CRLF & _
"double u;" & @CRLF & _
"" & @CRLF & _
"signed " & @CRLF & _
" long long " & @CRLF & _
" int function1 ( int j, int n);" & @CRLF & _
"" & @CRLF & _
"void main(int) {" & @CRLF & _
" int ii;" & @CRLF & _
" double jj;" & @CRLF & _
" long kk;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")