using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.{6,25}$)_?[A-Za-z](?:[-_]?[A-Za-z0-9])+_?";
string input = @"user_
usEr-nAme
uSer_naMe-Two_
_Userna-Me_tHree-and-four";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}