re = /^[(Administrators)(LOCAL SERVICE)(NETWORK SERVICE),\s]+$/
str = 'Administrators,LOCAL SERVICE,NETWORK SERVICE
LOCAL SERVICE,NETWORK SERVICE, Administrators
Administrators,LOCAL SERVICE,NETWORK SERVICE,phil'
# Print the match result
str.match(re) do |match|
puts match.to_s
end