// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[(Administrators)(LOCAL SERVICE)(NETWORK SERVICE),\s]+$").unwrap();
let string = "Administrators,LOCAL SERVICE,NETWORK SERVICE
LOCAL SERVICE,NETWORK SERVICE, Administrators
Administrators,LOCAL SERVICE,NETWORK SERVICE,phil";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}