using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\A.*Total IDOCs processed: \K\S+";
string input = @" 2024 Sep 11 19:26:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15705 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:27:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15710 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW
2024 Sep 11 19:28:57:173 GMT +1000 Info [Adapter] -000091 Total IDOCs processed: 15713 tracking=#HOZUdKqDs4V8vU8meK-7fayElTI#BW ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}