#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?su)(?|(?:@can|hasPermissionTo|hasDirectPermission)\(\s*(?P<quote>['"])(?P<string>.*?)\1\)|\((?P<quote>['"])can:(?P<string>.*?)\1\)|\(\[[^][]*(?P<quote>['"])can:(?P<string>.*?)\1[^][]*]\))"
Local $sString = "@can('event-tools::menu.view')" & @CRLF & _
"$this->middleware('can:access registration check');" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Route::prefix('administration')->middleware(['auth', 'verified', 'can:access admin area'])->group(static function () {" & @CRLF & _
"" & @CRLF & _
"Route::prefix('organisation/{organisation}')->middleware(['auth', 'verified', 'can:access organisation area', 'mustHaveOrganisation'])->group(static function () {"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")