use strict;
my $str = '@can(\'event-tools::menu.view\')
$this->middleware(\'can:access registration check\');
Route::prefix(\'administration\')->middleware([\'auth\', \'verified\', \'can:access admin area\'])->group(static function () {
Route::prefix(\'organisation/{organisation}\')->middleware([\'auth\', \'verified\', \'can:access organisation area\', \'mustHaveOrganisation\'])->group(static function () {';
my $regex = qr/(?|(?:@can|hasPermissionTo|hasDirectPermission)\(\s*(?P<quote>['"])(?P<string>.*?)\1\)|\((?P<quote>['"])can:(?P<string>.*?)\1\)|\(\[[^][]*(?P<quote>['"])can:(?P<string>.*?)\1[^][]*]\))/sup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}