import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "</?[\\w]+([\\s|\\w]+\\=\\\"[\\s|\\w|\\.|\\@|\\%|\\:|\\/]*\\\")*>";
final String string = "<HTML>\n\n"
+ "<HEAD>\n\n"
+ "<TITLE>Your Title Here</TITLE>\n\n"
+ "</HEAD>\n\n"
+ "<BODY BGCOLOR=\"FFFFFF\">\n\n"
+ "<CENTER><IMG SRC=\"clouds.jpg\" ALIGN=\"BOTTOM\"> </CENTER>\n\n"
+ "<HR>\n\n"
+ "<a href=\"http://somegreatsite.com\" name=\"asd\" surname=\"\">Link Name</a>\n\n"
+ "<a href=\"https://somesite.com\" name=\"\" surname=\"100%\">support@yourcompany.com</a>\n\n"
+ "<P> This is a new paragraph!\n\n"
+ "<P> <B>This is a new paragraph!</B>\n\n"
+ "<BR> <B><I>This is a new sentence without a paragraph break, in bold italics.</I></B>\n\n"
+ "<HR>\n\n"
+ "</BODY>\n\n"
+ "</HTML>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}