# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"</?[\w]+([\s|\w]+\=\"[\s|\w|\.|\@|\%|\:|\/]*\")*>"
test_str = ("<HTML>\n\n"
"<HEAD>\n\n"
"<TITLE>Your Title Here</TITLE>\n\n"
"</HEAD>\n\n"
"<BODY BGCOLOR=\"FFFFFF\">\n\n"
"<CENTER><IMG SRC=\"clouds.jpg\" ALIGN=\"BOTTOM\"> </CENTER>\n\n"
"<HR>\n\n"
"<a href=\"http://somegreatsite.com\" name=\"asd\" surname=\"\">Link Name</a>\n\n"
"<a href=\"https://somesite.com\" name=\"\" surname=\"100%\">support@yourcompany.com</a>\n\n"
"<P> This is a new paragraph!\n\n"
"<P> <B>This is a new paragraph!</B>\n\n"
"<BR> <B><I>This is a new sentence without a paragraph break, in bold italics.</I></B>\n\n"
"<HR>\n\n"
"</BODY>\n\n"
"</HTML>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.