#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!\d)([.,!?])(?![.,!?\d])|\s{2,}"
Local $sString = "Hello my friend.There should be a space after sentence periods and commas, but that should not apply to 40.381,32 numbers."
Local $sSubst = "$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)