package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_name=(?:[^"]*"){3}`)
var str = `_name=aVlTcWRjVG1YeDhucWdEbVFrN3pSOHZ5QTRjOEJZZmZUZXNIYW1PV2RGOWYrczBhVWRmdVJTMUxYazVBOE8zQ3JNMmNVKzJLM2JJTzFON3FiLzFHUE0xY0pkdz09LS1jbkkwaWoxUUl3YVhMMkhtZHpaOW13PT0"%"3D--57356371d167f"foo"bar"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}