use strict;
my $str = '[data-user="12345" data-userId="678910"]
John Smith
[/]';
my $regex = qr/\[(data-user="\d+")\h+(data-userId="\d+")\]\s*(.+?)\s*\[\/\](.*)/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}