#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[,](?![^(]*\))"
Local $sString = "&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)