re = /^\[(?!END).*]$/mi
str = '[ITEM1]
banana
peach
apple
orange
grapes
[END]
[ITEM3]
tennis
bowling
[END]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end