re = /(,\s+)|([:])/
str = 'Hey,This comma will be captured.
hey, this won\'t be captured.
Hey:this colon will be captured.
Hey: this colon will be captured too.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end