$re = '/(?<= )(?=[_{])|(?<=[_}])(?=\W)/m';
$str = 'Here is my very _special string_ with {different}, types of _delimiters_--that might _101_ even {repeat a few times}.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);