$re = '/^[a-zA-Z0-9]+(?: [a-zA-Z0-9]+)*$/m';
$str = 'good string string
bad string string1
bad string string2
bad string string3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);