use strict;
my $str = '01/01';
my $regex = qr/^(0?[1-9]{1}|1[0-2]{1})\/([0-9]{2})$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";