#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)roll (\d+)d(\d+)([\+-]\d+)?$"
Local $sString = "roll 1d10" & @CRLF & _
"roll 1d100" & @CRLF & _
"roll 1d20" & @CRLF & _
"roll 1d1234" & @CRLF & _
"roll 1d20+1" & @CRLF & _
"roll 1d20-1" & @CRLF & _
"roll 1d20*1" & @CRLF & _
"roll 1d20a1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")