import re
regex = re.compile(r"roll (\d+)d(\d+)([\+-]\d+)?$", flags=re.IGNORECASE)
test_str = ("roll 1d10\n"
"roll 1d100\n"
"roll 1d20\n"
"roll 1d1234\n"
"roll 1d20+1\n"
"roll 1d20-1\n"
"roll 1d20*1\n"
"roll 1d20a1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")