import re
regex = re.compile(r"(([a-zá-ú]+)[\.,]?\s[A-ZÃ-Úa-zá-ú]){3,}\1", flags=re.MULTILINE)
test_str = ("¡No, no, no, no, no, no, no, no, no!\n\n"
"No no no no no no.\n\n"
"No. No. No. No. No. No.")
subst = "$1$1"
result = regex.sub(subst, test_str)
if result:
print(result)