const regex = /\b(?=[a-zA-Z_%-]*[0-9])[a-zA-Z0-9_%-]{5,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=[a-zA-Z_%-]*[0-9])[a-zA-Z0-9_%-]{5,}', 'gm')
const str = `/someService/US/getPersonFromAllAccessoriesByDescription/67814/alloy%20nudge%20w
/someService/NZ/asdNmasdf423-asd342e/getDealerFromSomethingSomething/FS443GH/front%20parking%20sen`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}