package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+-re-.+?-(.+)-\d+.+`)
var str = `re-medbedb-re-darksun-re-bit8k-khorosho-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
re-medbedb-re-darksun-re-bit8k-dsdsdsd-li-chto-kazhdyi-den-sozdayutsya-novye-kriptovalyuty-20161102t054454811z
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}