#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "v?\s*(\d+(\.\d*)*)+\s*(beta|build|b)\s*(\d+)"
Local $sString = "v1.23beta125" & @CRLF & _
"v1.25.458 beta 129" & @CRLF & _
"v1 beta 129" & @CRLF & _
"1.2.4 beta 134" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")