#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\\)".*?(?<!\\)""
Local $sString = " shete we go "\"yeah" something rl" & @CRLF & _
"semy something "dugs" hdis "and \"this\" os cool"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"""" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""\fdfdf"" & @CRLF & _
""word\"" & @CRLF & _
""\word"" & @CRLF & _
""\word\""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")