re = /(?<!\\)".*?(?<!\\)"/m
str = ' shete we go "\\"yeah" something rl
semy something "dugs" hdis "and \\"this\\" os cool"
""
"\\fdfdf"
"word\\"
"\\word"
"\\word\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end