#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^|\s)(\w+)(?=\s|$)"
Local $sString = "random" & @CRLF & _
"#random " & @CRLF & _
"?random" & @CRLF & _
"random?" & @CRLF & _
"ran?dom" & @CRLF & _
"rand#om" & @CRLF & _
"random#" & @CRLF & _
"" & @CRLF & _
"XUY" & @CRLF & _
"ХУЙ ПИЗДА ДЖИГУРДА ЫВФХВЛБАДВА"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")