re = /(^|\s)(\w+)(?=\s|$)/
str = 'random
#random
?random
random?
ran?dom
rand#om
random#
XUY
ХУЙ ПИЗДА ДЖИГУРДА ЫВФХВЛБАДВА'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end