#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?>\S+[^\S\n]+){3,}?(\S+?)\K\1(?!\S)"
Local $sString = "00101 blah 0000202 thisisasentencethisisasentence 99929" & @CRLF & _
"00102 blah 0000202 thisisasentenc1thisisasentenc1 999292"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)